Service Advisory: iLab & CrossLab Connect

Incident Report for Agilent

Resolved

The incident is resolved. All sites are working as expected.
Posted Oct 21, 2025 - 03:40 UTC

Update

AWS has reported that the recent infrastructure outage is now resolved. Our Agilent applications, including iLab and CrossLab Connect, continue to recover across all impacted regions. We are seeing ongoing improvements and will actively monitor our systems to ensure full stabilization.
Posted Oct 20, 2025 - 20:06 UTC

Update

AWS Outage Impact Expanded to North America, including Canada.
Posted Oct 20, 2025 - 17:40 UTC

Update

AWS Outage Impact Expanded to All US Regions
Posted Oct 20, 2025 - 17:30 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 17:00 UTC

Monitoring

Users may be experiencing slowness or temporary site outages due to ongoing AWS infrastructure issues today. We are actively monitoring the situation.

You can track AWS progress and updates here: AWS Health

Services should stabilize once AWS resolves the incident. Thank you for your patience.

For any questions regarding an application, you can contact iLab Support at ilab-support@agilent.com or CrossLab Connect/ Asset Monitoring Support at crosslab.support@agilent.com.
Posted Oct 20, 2025 - 16:11 UTC
This incident affected: CrossLab Connect (Asset Monitoring, CrossLab Connect Application) and iLab (iLab Canada, iLab Canada API, iLab DFCI, iLab DFCI API, iLab Stanford, iLab Stanford API, iLab US API, iLab US Primary).