Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 06, 2024 - 07:30 UTC
Scheduled
Friday December 06, 2024, at 7:30AM - 8:30am (UTC), routine maintenance has been scheduled for CrossLab Connect.
During this planned maintenance, the CLC application/site will be temporarily unavailable. The expected downtime is approximately one hour. We apologize in advance for any inconvenience and appreciate your understanding.
Please do not hesitate to contact Agilent CrossLab Support via crosslab.support@agilent.com, with any questions or concerns.
Posted Dec 04, 2024 - 16:39 UTC
This scheduled maintenance affected: CrossLab Connect (CrossLab Connect Application).