Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 16, 2025 - 06:00 UTC
Scheduled
On Wednesday April 16, 2025 at 6:00AM (UTC), routine maintenance has been scheduled for the following CrossLab Connect server instance:
- CrossLab Connect
Maintenance is planned for 30 minutes and during this time, please take note that users will be experiencing server downtime of no more than 30 minutes. We apologize in advance for any inconvenience that may be caused.
Please contact Agilent CrossLab Connect Support at crosslab.support@agilent.com, with any questions or concerns.
Posted Apr 16, 2025 - 06:00 UTC
This scheduled maintenance affected: CrossLab Connect (CrossLab Connect Application).