Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 18, 2026 - 02:31 UTC
Scheduled
On Saturday April 18, 2026, at 2:30AM (UTC), routine maintenance has been scheduled for the following CrossLab Connect server instance:
- Asset Monitoring
Maintenance is planned for 1-hour and during this time, please take note that users may experience server downtime for the entirety of the maintenance window. We apologize in advance for any inconvenience that may be caused.
Please contact Agilent CrossLab Connect Support at crosslab.support@agilent.com, with any questions or concerns.
Posted Apr 16, 2026 - 19:56 UTC
This scheduled maintenance affected: CrossLab Connect (Asset Monitoring).